Help please

Talk about general things related to the new VW Scirocco in here.

Help please

Postby Lewis1988 » Wed Oct 28, 2020 2:57 pm

Hi all

I have had a break pad worn warning appear in the last few days.

On inspection the brakes are fine but the cable is damaged

I am Struggling to find a replacement cable harness

The cable connects to the brake pad and splits and another connector on suspension arm

Any help is appreciated
Lewis1988
 
Posts: 47
Joined: Thu Aug 20, 2015 9:33 am
I drive a: GT 2.0 TSI
In: Candy White
With a: Manual box
Options: Front spoiler
19" Interlagos Alloys
RNS 510
Rear parking sensors
Centre armrest
Titan Black 'Vienna' Leather
Heated seats
Dynamic chassis control (DCC)
Voice activation
Winter pack

Re: Help please

Postby Jimjimjim » Wed Oct 28, 2020 5:42 pm

Is dealership out of the question?

https://volkswagen.7zap.com/en/rdw/scirocco/sci/

You could look up the part number here and try call a dealership, euro car parts or on autodoc (a German parts website).
Jimjimjim
 
Posts: 40
Joined: Fri Aug 23, 2019 9:40 pm
I drive a: GT 2.0 TSI
In: Candy White
With a: Manual box

Re: Help please

Postby StuartyBoy » Thu Oct 29, 2020 6:55 pm

I think you’ll find the cable harness is not an easy replacement. Is the cable damaged at the connector end? I had the same issue as you where the brake wear light came on but the pads are good. I found that the connector was cracked and water got into the contacts and corroded them. I fitted a replacement connector and all is good.
User avatar
StuartyBoy
 
Posts: 97
Joined: Mon Aug 05, 2013 10:35 pm
I drive a: GT 2.0 TDI 140/150
In: Rising Blue
With a: Manual box


Return to General Scirocco Talk

Who is online

Users browsing this forum: No registered users and 136 guests